Canon EOD 60D hot-shoe problems

I have a strange problem with my new EOS 60D.

I'm shooting our Christmas party and I can not get the camera's built-in flash to pop up. I am using Av-mode. As always, I press the flash pop-up button. This time, nothing happens! I go to Menu → First Camera Tab → Flash Control → Built-in Flash Func. and it gives me a message saying something like “This option not available when external flash connected”. But I don't even own an external flash, and nothing is connected.

Please help.

If you want to subscribe to this thread and get an email every time the thread is updated, you need to register. Registration is free and carry no obligations.

5 responses:

Check the microswitch

There is a microswitch to detect the presence of an external flash in the Canon hot-shoe. If this somehow gets stuck, you'll have this problem.

Look underneath the right rail of the camera's hot-shoe (when looking from the back of the camera). There is a spring there, and under the spring there is a minute black plastic pin than engages a microswitch. When you put an external flash in the hot-shoe, the spring is pressed down and this pressure is detected by the microswitch. If this spring does not release properly, the microswitch becomes jammed. Then you'll get the message that an external flash is mounted, even when there is none.

To correct this, you may use a watchmaker's flat-head screwdriver. Insert it under the spring and gently lift the spring so that it no longer jams the microswitch.

avatar
Thank you

Thanks for this write up radchat. It happened to me last night while preparing for a shoot. I was tempted to raise one of those spring rails in the shoe but decided to wait for professional guidance before I try anything. Your guidance worked. I saw the switch you referred to and I am now using my speed flash remotely.
Thanks again.

avatar
THANK YOU, THANK YOU, THANK YOU!!!!!!!!!

THANK YOU!!!!! I have been having the same problem, and now it is fixed!!! I will always look here for answers first!!!!!!!

avatar
Thanks also from me.

I had the same problem, and the fix above worked perfectly.

I was already tempted to send the camera to service to Canon. It takes them typically 4 weeks to sort out things take that.

I am sure that they know this problem very well, meanwhile.

avatar
Andy - 2012-09-03 14.27

had same prob on holiday - cost me some irreplaceable shots - nice to know i'm not the only one, commissurations to all. does Canon have a response to this on going design flaw?

Leave a comment.

Title (optional):

Comment:

Enter the caracters below into the Verify-field to indicate that you are not a spambot.
To avoid having to enter a verify code, register at the site and log in before posting.
CAPTCHA Image new image 2
Verify code:  (Required.)
Your name:   (Required.)
Your email:   (Will not be published.)

Notice: If you feel that you have found inappropriate content on this site, please let us know by contacting us with the with the URL of problematic page. TIA.

This page is from: http://dpanswers.com/roztr/content_show.php