Bookmark and Share

Nissin Di866 Update Available

Here's the missing manual!
by Gisle Hannemyr
Published: 2010-07-30.

As of July 29, 2010, there is a firmware update for the Nissin Di866 on Nissin's download page. I have downloaded it and tried to install it on the oldest and most buggy of my two Nissin Di866 units. It installs fine, but so far, I haven't noticed any improvements. The bug that has been fixed on my newest Nissin Di866 is still present in the old one after installing the upgrade.

What follows is a detailed report from my upgrade session. Since the process is quite elaborate, you may want to read through all of it before you try to upgrade.

Caution: If the “sleep” bug has been fixed in your flash, installing this software may re-introduce it. However, I am not sure about this. For obvious reasons have I not tried to find out.

Downloading and Installing

When you visit download page. You'll find no date or version number for the upgrade, and the instructions are pretty skimpy. This is what it says:

Please download the following application and execute it on your PC for Firmware Update.

Di866 firmware: Setup.exe

<System Requirement>
Cable: USB cable (A:miniB type)
OS: Windows XP, Windows Vista
Ram: 1G or above
Internet connection needed
Remarks: some of Firewall and anti-virus software may block the firmware execution.

I think they at least could have supplied some release notes that told us about what this release is supposed to fix, but – no.

My configuration and equipment meet all their requirements, so I download Setup.exe to my own computer. What follow is a screen-by-screen description of what I did, and the outcome.

When I start Setup.exe, Windows XP has the good sense to warn me about the hazards of running software of unknown origin:

Warning.

Since I downloaded it from Nissin's official website, I believe it is the genuine article, so I permit it to run. The next screen looks like this:

Installation program start screen.

I press Install. This prompts the setup program to download the actual Download Manager (DM) that I assume will handle the update process. This is how the download screen looks like:

.

I also get this little message.

.

And this message.

.

I leave the destination folder unchanged, as requested, and press Extract. After a short while, I get the following status update:

.

Now installation of the Download Manager is almost done, and the system is ready to run the thing. This is communicated with the following screen:

.

I make sure “Run Di866 DM Startup 1.0” is ticked, and press Finish. This results in the following security warning from Windows XP.

.

Well, I still trust Nissin, so I press Install, and this completes, I think, the installation process. Now, the Download Manager is going to run.

Running the Nissin Di866 Download Manager

The Download Manager (DM) starts up with a screen presenting itself that will look like this if all is well:

.

Notice the little box Connect Status at the bottom of the panel above, where it says “Network Connected” next to a green square. Some people report that they instead see “No Network” with a red square, even if their computer is connected to the Internet. I am not able to reproduce this error. If you know what causes this, and/or how to fix it, please leave a comment below.

Since I have the required Connect Status, I proceed by pressing the Software tab. This brings me to the following, rather mysterious page:

.

It says that the “Current Firmware” is “Di866_N_Nissin_firmware_1”. The “Di866” is obviously the model name and “N” probably stands for ”Nikon”. But where does this information come from? At this point, the Nissin flash unit is not physically connected to the PC, so it can't refer to the current firmware in the flash?

Anyway, I want updated firmware, so I make sure that “Nikon” is selected and press the button that says Update Firmware. This produces the following notice, hinting that English is not the first language of whoever writes Nissin's software.

.

In this note, Nissin explains: “This means the Di866 firmware has currently updated from Nissin official website”. which probably is some some sort of confirmation that the updated firmware has been downloaded.

The Software tab now looks like this. Notice that the field labelled “Updated Firmware” is now filled in with the same string as the field labelled “Current Firmware”.

.

I am not sure what happened, but my best guess is that the DM has downloaded the latest and greatest firmware from Nissin's site, and that this version is the same version as the firmware that came with the DM.

I am now ready to proceed to the last tab, labelled Download. The DM comes with an embedded tutorial of download mode. I ran through this tutorial a couple of times before I tried anything. Below, I record the steps I took, along with screen captures from the tutorial.

Start.

At this point, I grabbed one of my Di866 flash units, and turned it on.

Step 1.

You have to take this literally, press the [On/Off] switch, hold it, and then press the [Pilot] switch. It is easy to turn the unit off instead, but it becomes simpler with a bit of practice. Doing this displays a table on the Nissin's display with two columns of numbers and letters.

Result of step 1.

According to this note on Nissin's website, row “C” indicates firmware version. The latest versions as of July 2010 are:

  • Canon: 2
  • Nikon: 4

I currently hold two Nissin units (both for Nikon). Below I've reproduced the data that appear in the table that is displayed when you press these two buttons, along with the serial numbers of the units and the month and year I received them.

Serial #:
Month Year:
980432068
Oct. 2009
042774197
Jul. 2010
A11
B37
C24
M12

From this, I can see that my oldes unit is running version 2 of the firmware, while my newest unit is already running the latest version of the firmware.

.

After completing step two, I see a white screen that indicates that the Di866 is in download mode.

White screen.

I now connect my oldest Di866 (serial # 980432068) to the PC with the USB-cable. When I do this, the operating system tells me that I need to install a driver for a device named “AT90USB162 DFU”, otherwise, the device will not function.

(I botched installing the device driver when installing on Windows XP. I then switched to another computer running Windows Vista for a fresh start. This is why the screen shots from the last part are from Windows Vista. However, botching the device driver installation was my fault and has nothing to do with the upgrade.)

.

To install the driver, you must select Locate and install driver software.

.

Here you must pick: I don't have the disc. Show me the other optons. One if these options is to browse computer for driver. Select this one, and search the directory where the Di866 DM-software is located.

.

Again, Window warns me about the harms of unknown software. However, I trust the good people of Atmel Norway (they are in Trondheim.)

.

After I press Install, transferring the new software to the flash unit takes some time, but after I while, I get the message “Download complete”:

.

After I press OK, focus returns to the DM. It also tells me “Download success”:

.

I remove the USB-cable, and then remove the batteries to exit download mode. I also go back to the software page in the DM, to check firmware version. It still says: “Di866_N_Nissin_firmware_1”.

I also repeat step 1 to re-examine the table with letters and numbers. The value in the C-line (firmware version) has changed from 2 to 4, confirming that my oldest unit is now running the lastest version of the firmware (version 4).

 Old unitNew unit
BeforeAfterNot upgraded
A111
B337
C244
M112

As for the other three lines, the numbers in the B- and M-line are different that those numbers in the newer unit I own.

Testing

As noted in my review, my two Di866 units work different. The following software bug is present in the older unit, but not in the new:

  • It sometimes goes to sleep in plain slave mode.

When I test the updated unit, I find no change. I.e.: the bug is still there.

This also means that I shall not attempt to install this software on my latest unit. Doing so may actually reintroduce the bug that have been fixed!

I am interested in hearing from others that have used the DM to upgrade their Nissin. Is anything changed by the upgrade? Please use comment field below.

Bookmark and Share

26 responses:

avatar
WOW!!!!!

I'm so glad you went first! I think I will probably follow in your footsteps and try the dnload, but it will have to be tomorrow because I will need a full night's sleep to do this one!

Clutching at straws here,gisle, but did you try wireless HSS/FP after the update?

Thanks again for all you do on behalf of the Nissin flash units and their owners.

Regards, Jim

avatar
Still no wireless FP

I am sorry to report that I tried wireless FP after the update, and it still don't work.

avatar
subflash 1/8

i am curious to know if the upgrading process introduced more options for the subflash. Actually, the subflash of the canon version can be turned down til 1/32 while the nikon stop at 1/8. Is it the same after the upgrade?

avatar

Yes, it is the same.

The sub-flash after the upgrade (and in my newest unit) only go down to 1/8 power. Having the option to set it lower would have been very helpful, as it is usually too poweful at 1/8 power.

avatar

My unit says 1641 on ABCM.

Observation of your result show only updating C column to 4. I guess I do not need this firm ware update.

I also do not know what those letters and numbers means. I wish it more clear like straight firmware version like Nikon Camera itself.

Thanks for all your review of this unit and so as this post. Because of you, I've got Di866 and good to know the current limitations. I also hope Nissin will address the issue you have reviled. I also secretly hoping they will implement iTTL-BL mode.

Thanks again.

avatar
1431 to 1441

Upgrade done from 1431 to 1441, Nikon version. Don't know if sleep bug is still here, I will post next days. I think that ABCM are only there because the funny software programmer needed a place to write the version and he/she found that table :) Mine Nissin is 3 month old, May 2010, Romania.

avatar
4 upgrades

It seems all that happens is the 'C' changes to '4'.

I had 2 of 1321's change to 1341.

& 2 of 1221 change to 1241.

The bad news is I checked that 1 of the 1221's did not have the sleep bug beforehand, ..... now it does.

So I would not recommend this upgrade if you do not have the sleep bug.

BTW the sleep bug does not affect iTTL slaves and will work with radiopoppers.

avatar
what is the sleep bug?

How can I see if I have the “sleep bug”?
How to test please?

avatar

The sleep bug is when the Nissin Di866 goes to sleep in plain slave mode and then refuse to wake up. Here's how to test for it:

  1. Load your Di866 with freshly charged batteries and turn it on.
  2. Set the Di866 up as a plain slave in manual mode (brown menu). Select “SF” or “SD” (use the appropriate mode depending on what you use as lead flash).
  3. Set the manual power of the Di866 to 1/1 (important!).
  4. Position the Di866 off-camera. Make sure you can observe the LCD screen and the pilot lamp at the back.
  5. Wait until the Di866 enters sleep mode. This takes about 30 seconds of inactivity. You can tell the Di866 is in sleep mode by looking at the back of the flash. When the LCD screen is off (dark), the Di866 is in sleep mode.
  6. Fire your lead (master) flash. The Di866 shall now fire as a slave flash. This first slave always works.
  7. After the Di866 has fired as a slave, the pilot lamp will blink red for some time (very briefly if your batteries are good). This is when it is recharging.
  8. Wait some seconds, and then observe the pilot lamp. At one point it will start blinking green again (sometimes it is alternating with red, sometimes not). Green blinks means the Di866 has finished recharging and is supposed to be ready. Fire your master flash again. Does the Nissin Di866 fire as a slave? If it does not fire, then you have a unit with the sleep bug. The Di866 is now in an unresponsive state and will not fire as a slave flash until you “wake it up” by touching one of the buttons on the back.

The workaround for the sleep bug is to dial down the power to less than 1/2 power and not fire too rapidly. Appearently, the unit only enters the unresponsive state if it becomes completely discharged. Setting half power and only firing when it is fully charged ensures that it never reaches that state.

avatar
tested, sleep bug still here

from 1431 to 1441, Nikon version, sleep bug still here :(

Some explaination of the firmware version table:
http://www.nissindigital.com/download_readme.html.

Nissin's Answer to Firmware Update Request

Here is the conversation I have had with Nissin related to a Di866 Nikon Firmware Upgrade. I am not happy with the answer and really do not understand why they don't want to make these small improvements that can improve their product a lot. Maybe it will be a good idea if everybody write them asking for new features in order to get the firmware update.

ME:

Dear Sirs,
I recently bought in Spain the Di866 with S/N 061074019. Even though I am very happy with the flash, there are some points that I am sure can improve the flash a lot through a firmware update:

  • Subflash power can only be lowered to 1/8th of its power. I find this too much and think that it is necessary to add further adjustment until 1/32th like the Canon version.
  • In all modes it will be very helpfull if ISO and f-stop number are shown on the screen.
  • As soon as f-stop number and ISO setting can be read from camera in TTL and A mode, I think it will be easy to implement f-stop and ISO reading for Manual and Av modes.
  • Menu navigation even when they have soft transition, I find them slow. Maybe transitions can be configured by user to be soft or fast.

I would be very grateful if you consider this modifications for following next firmware releases.

Thanks a lot for your attention.
Best Regards,

NISSIN:

Dear Sir/Madam,
Thank you for your kind suggestions.
For current models, we are not able to add it but will consider it for future models.
Thank you very much.
Nissin
www.nissindigital.com

ME:

Dear Sir,
Thanks a lot for your answer, but I don't really understand why you are unable to lower the Subflash power to the same levels than the Canon version (1/32). Furthermore, I don't understand how you are able to read ISO an f-stop for TTL and Auto, but not for Manual mode. If you read these values, how it is posible that you can not show them in the screen?

Thanks again and best regards,

avatar
Nissin User

Very good instructions, helped me to install new firmware on my Nissin Di866 Canon flash which I was having a problem with.

Just as an update to your instructions: After Installed Button is pressed to Install Device Software for Driver you need to wait for Vista window (First Time Installing Driver on PC) DRIVER INSTALLED, click Close, and then at Nissin Download Manager Click Download.

Also, when installing first time on XP system: When you Insert Nissin Flash before doing download, you need to manually go through Windows Control Panel and find and install AT90USB162DFU Hardware from Di866 Directory. As added note if download and drivers are not installed correctly the first time, you cannot run Nissin Device Manager again unless it is uninstalled both from the Start Menu and from Control Panel add and remove programs, also did not work until I disabled Norton Virus and firewall options.

Thank you again.

avatar
sleep bug

In 1221, Canon version, sleep bug still here.

 

avatar
Source code

Do you think we can get the source code somehow? It will be nice to have it for Nikon. I have tried disasembling the .hex but it is really hard to follow for me.

Thanks.

avatar
Firmware dump

Yeah, have anyone idea how to dump firmware??

 

avatar
Update not helping...

Hello every one, and thank very much to Gisle, I could not have done this update with out his article.

WHAT A BAD CUSTOMER SERVICE THIS COMPANY HAS!!!!!, from the beginning of my ownership I express to them that the subflash was unusable, here we are one year latter and nothing, and exactly what is this update about???, it just changes a 2 for a 4.... Ok, sorry, but had to rant about this.

I own two of this flashes and one of them just stopped doing iTTL (Nikon Version) and I hoped the update would help but didn't, anyone here having the same issue? I had these flashes for more than a year and I'm getting desperate...with out iTTL, is just another $ 100.00 flash.

I we don't have answers I suggest that we dump all of our frustration in the reviews at the store sites were this flash is sold….maybe we get their attention.

avatar
Nisssin Di866 firmware update: No network

Hey, after I install and start the download manager it always says that there is "no network".
Tried on different systems. Please help.

Eventhough this is the case it changed the third number from 1 to 2 i think.

avatar
Nisssin Di866 firmware update: No network

The same problem, "Connect status: no network".

Are Nissin guys not capable of long term support of their goods?

avatar
No network

I also have the red No Network indication when I try update. I have tried on Windows 7 and Windows XP to no avail. Searching the web is proving fruitless.

Any ideas?

avatar
Firmware

I have tried updating from 3 different machines now and all are the same, a red square with no network displayed.

If I download the software it does download and appears to update the flash as the “C” number changes, but then it no longer interfaces with my camera, EOS 600D.

avatar
Firmware - No Network

I have tried the download manager and does the downloading part without the Network Connection. What I get is 1643. Don't really remember the number combination before. Maybe 1523…

avatar
Update firmware No Connection - Fixed

For those unable to download the new firmware may try the following step (as I tried and successfully update my firmware):

Double Click on
Di866_C_firmware_1 for canon
Di866_C_firmware_1 for nikon

the windows will pop up an download screen. Once the pop up screen close automatically, relaunch the Nissin Application and go to the Download Tab directly.

Following the instruction and press the download. The firmware is not updated.

avatar
No Network Connection

So a quick disassemble of the Click-Once application shows that the network connection fails if it is not possible to ping the following address 'www.nissindigital.com' (in my case I get a 'request timed out' if I do this from a command window).

If this fails, then it is not possible to download the latest version of the firmware (currently this doesn't seem to have been updated anyway) using the download manager.

You can check the latest version of the software, by downloading the following text file (text file contains firmware names separated by carriage returns): http://www.nissindigital.com/download/Di866_Version.txt.

If you wish to download the latest version of the firmware, you should use the firmware name from the text file (for your camera manufacturer) to download using the following link: http://www.nissindigital.com/download/[firmwarename].exe.

For example, the latest (at this time) versions of the Nikon firmware can be downloaded using this link:
http://www.nissindigital.com/download/Di866_N_firmware_1.exe.

And the Canon version using this link:
http://www.nissindigital.com/download/Di866_C_firmware_1.exe.

If you attach the Di866 to the computer, after putting in download mode (allow device drivers to install), you can then run the firmware file directly to update.

Hope this makes sense, don't have a lot of time right now to go into more detail.

Good luck!

avatar
Driver problem!

Hello,
my addition to steves great tutorial is that at least on my Windows 8 PC the device driver for the flash failed to install.

After a bit of research I found out that you can download a newer version of the USB driver and you can find it here: http://sourceforge.net/projects/dfu-programmer/.

Just download and then go to Device Manager in Windows, select the device (it had some cryptic name I cannot now remember, but it will be highlighted with a yellow marker). Then manually update the driver by pointing out the device driver installer to look in the folder you extracted the "dfu-programmer".

Then you can follow steves advices!

PS. However, updating the flash firmware didn't fix my issue of the flash firing before the exposure begins :(

avatar
64 bit windows systems Driver problems

On all Windows x64 systems (64 bit) installing unsignad drivers is disabled by default.

In order to get this guide to work (except the no network feature solved obove) you need to disable this feature and then excecute the driver install.

Since I'm on a Win8.1 x64 system this is how i did it:

1.Enable installing unsigned drivers, this will require pc reboot. Follow guide http://www.howtogeek.com/167723/how-to-disable-driver-signature-verification-on-64-bit-windows-8.1-so-that-you-can-install-unsigned-drivers/.

2. Install drivers for the flash, right click atmel_usb_dfu.inf in C:Program FilesDi866_DM and select install, answers yes to required questions. You now have the driver installed.

3. Launch Nissin Di866.application. And complete the download section, if all went well you now have an upgraded firmware on your flash.

Leave a comment.

Title (optional):

Comment:

Enter the caracters below into the Verify-field to indicate that you are not a spambot.
To avoid having to enter a verify code, register at the site and log in before posting.
CAPTCHA Image new image 2
Verify code:  (Required.)
Your name:   (Required.)
Your email:   (Will not be published.)
844
This page is from: http://dpanswers.com/content/nissin_flash_dm.php